Disable software keyboard

I can disable the software keyboard on an MC92N0 manually using:

 

Settings > Language & input > Keyboard & input method > Enable Hardware (Physical keyboard)

 

This stops the software keyboard coming up automatically when an input field has the focus.

 

Can I do this with StageNow? I know I can set the language but I do not see an option to enable the hardware keyboard and disable the software keyboard.

Peter Arcuri
Unfortunately, that feature

Unfortunately, that feature isn't available in StageNow. However, you could potentially use the Null Keyboard app to replace the default keyboard. This could help achieve the results you're looking for. Since the MC92N0 device doesn't have google play services, you can download the app from https://apkpure.com/null-keyboard/com.wparam.nullkeyboard

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Rodney Hills
Using NullKeyboard, how would

Using NullKeyboard, how would you enable it from StageNow ?

Alternatelly, is there a call from "adb" that could enable ?

Thx

Rod Hills

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Matteo Boldrin
Hi Peter,I'm interested too.I

Hi Peter,

I'm interested too.

I'm trying to configure NullKeyboard through StageNow but I've got an error.

this is the steps i follow:

- Create a profile selecting Xpert Mode

- Select UiMgr (Manage UI configuration)

- Set Default Input Method --> Change current input method

- defined the Package name: com.wparam.nullkeyboard

- defined the class name of input method: android.view.InputMethod

But when i scan the barcode generated by StageNow i've got an error

Original Error message: No such input method supported on device

I really don't know how to do disable the google keyboard using StageNow

Thanks in advance for any tip

Matteo

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
I think the class name is

I think the class name is going to be something like com.wparam.nullkeyboard.NullKeyboard.  If you see the examples at UI Manager - Zebra Technologies Techdocs  this is using com.android.inputmethod.latin.LatinIME which is the class that extends InputMethodService (java/src/com/android/inputmethod/latin/LatinIME.java - platform/packages/inputmethods/LatinIME - Git at Google )

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Matteo Boldrin
Hi Darryn, thanks for your

Hi Darryn, thanks for your reply..

I've just tried with the com.wparam.nullkeyboard.NullKeyboard as class name and now I've a different error:

Original Error message

Error in set default input method: com.wparam.nullkeyboard,

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Interesting... I gave it a go

Interesting... I gave it a go because I am interested myself and I see the same error.  I do observe that the default IME has been changed to NullKeyboard however (i.e. when I select a text field the keyboard does not appear) so I am unsure what is causing that error.  When I go to the 'Manage keyboards' settings screen I notice I cannot disable everything BUT NullKeyboard - I always need to have some other keyboard enabled, either Gboard or Zebra's Enterprise Keyboard - although the default IME is still NullKeyboard.  I suspect Android requires some feature of a keyboard which is not exposed by NullKeyboard which could be causing the staging error but I'm unsure what that could be exactly.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Matteo Boldrin
Thank you very much Darryn,So

Thank you very much Darryn,

So it seems that it’s not possible to do it via StageNow.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments